Previous topic  Top  Next topic  Print this Topic
 

Creating a report with BIRT

 
1.From the top level menu select: Window -> Open Perspective -> Other....
2.Select Report Design and click on OK.

clip0392

A new view appears:

clip0393

3.Select your ontology project from the Navigator.
4.Make a right mouse click on the project and choose New -> Report.

A new dialog box appears:

clip0395

5.Select a project, give a name to the report and click on Next.
6.Choose a type of report and click on Finish.

clip0396

The report is generated:

 

clip0397

7.Create a new ObjectLogic Data Source.
a.Choose the tab Data Explorer. Then make a right mouse click on Data Source and select New Data Source.

clip0398

b.Select OntoBroker Data Source and give a name to the data source and click on Next.

clip0399

c)Fill out the fields and click on Finish.

  clip0400

8.Create a new data set.
a.Make a right mouse click on Data Sets and select New Data Set.

  clip0401

b.Fill out the fields and click on Next.

  clip0402

c.Choose the query for which the report will be created and click on Finish.

  clip0403

d.Click on OK.

  clip0404

9.Drag&Drop the data set element from the Data Explorer to the new report view to create a simple table view of your data.

See below for the result:

clip0406

10.Click on the Preview tab.

The result of the query appears:

clip0408

11.Switch back to the Layout tab.
12.Select Chart from the Palette to create a chart.

  clip0409

13.Drag&Drop from Chart to the report.

clip0410

A new dialog box appears:

clip0411

14.Select a chart type and click on Next.
15.Select the Use Data Set radio button and select the data set to be used.

  clip0412

16. Drag&drop the data column to the appropriate text field and click on Next.

  clip0413

17.Click on Finish

The chart is created:

clip0418

18.Click on the Preview tab.

You can see all of the generated charts.